bacula TL2000

Wysłane przez syndrom 
bacula TL2000 18 lip 2016 - 11:39:31

Send PM

Witam,
Nie mogę dojść do porozumienia ze spięciem biblioteki DELL z bacula.
Konfiguracja bacula-sd:
Autochanger {
  Name = Autochanger
  Device = Drive-1
  Changer Command = "/etc/bacula/scripts/mtx-changer %c %o %S %a %d"
  Changer Device = /dev/sg3
}

Device {
  Name = Drive-1                      #
  Drive Index = 0
  LabelMedia = yes
  Media Type = LTO-5
  Archive Device = /dev/nst0
  AutomaticMount = yes;               # when device opened, read it
  AlwaysOpen = yes;
  AutoChanger = yes;
   RemovableMedia = Yes;
   RandomAccess = No;
  Alert Command = "sh -c 'tapeinfo -f %c |grep TapeAlert|cat'"
}

# mtx -f /dev/sg3 status
  Storage Changer /dev/sg3:1 Drives, 24 Slots ( 1 Import/Export )
Data Transfer Element 0:Full (Storage Element 8 Loaded):VolumeTag = 000001L5                       
      Storage Element 1:Full 
      Storage Element 2:Full 
      Storage Element 3:Full 
      Storage Element 4:Full :VolumeTag=000002L6                       
      Storage Element 5:Full 
      Storage Element 6:Full :VolumeTag=000001L6                       
      Storage Element 7:Empty
      Storage Element 8:Empty
      Storage Element 9:Empty
      Storage Element 10:Empty
      Storage Element 11:Empty
      Storage Element 12:Empty
      Storage Element 13:Empty
      Storage Element 14:Empty
      Storage Element 15:Empty
      Storage Element 16:Empty
      Storage Element 17:Empty
      Storage Element 18:Empty
      Storage Element 19:Empty
      Storage Element 20:Empty
      Storage Element 21:Empty
      Storage Element 22:Empty
      Storage Element 23:Empty
      Storage Element 24 IMPORT/EXPORT:Empty
# mt -f /dev/nst0 status
drive type = 114
drive status = 1476395008
sense key error = 0
residue count = 0
file number = 0
block number = 0
Device status:
Autochanger "Autochanger" with devices:
   "Drive-1" (/dev/nst0)
Device "Drive-1" (/dev/nst0) is mounted with:
    Volume:      000001L5
    Pool:        *unknown*
    Media type:  LTO-5
    Slot 8 is loaded in drive 0.
    Total Bytes Read=0 Blocks Read=0 Bytes/block=0
    Positioned at File=0 Block=0
====

Used Volume status:
000001L5 on device "Drive-1" (/dev/nst0)
    Reader=0 writers=0 devres=0 volinuse=0
====

Jak próbuje uruchomić zadanie to mam, że nie znajduje żadnego wolumenu:
18-lip 11:36 B2-S01-BACKUP1-dir JobId 89: No prior Full backup Job record found.
18-lip 11:36 B2-S01-BACKUP1-dir JobId 89: No prior or suitable Full backup found in catalog. Doing FULL backup.
18-lip 11:37 B2-S01-BACKUP1-dir JobId 89: Start Backup JobId 89, Job=BackupClient1.2016-07-18_11.36.58_17
18-lip 11:37 B2-S01-BACKUP1-dir JobId 89: Using Device "Drive-1"
18-lip 11:37 B2-S01-BACKUP1-sd JobId 89: Job BackupClient1.2016-07-18_11.36.58_17 is waiting. Cannot find any appendable volumes.
Please use the "label" command to create a new Volume for:
    Storage:      "Drive-1" (/dev/nst0)
    Pool:         File
    Media type:   LTO-5
Jak próbuje label to błąd, że nie można:
Sending label command for Volume "000001L5" Slot 0 ...
No slot defined in catalog (slot=0) for Volume "" on "Drive-1" (/dev/nst0).
Cartridge change or "update slots" may be required.
3920 Cannot label Volume because it is already labeled: "000001L5"
Label command failed for Volume 000001L5.
Do not forget to mount the drive!!!

Co robię źle lub mi brakuje ?
Re: bacula TL2000 19 lip 2016 - 10:54:18

Send PM

Podaj wyniki polecenia: list volume=000001L5

--
Profesjonalne usługi Bacula: [www.bacula.com.pl]
Re: bacula TL2000 22 lip 2016 - 12:20:57

Send PM

Okazało się LTO-6 nie wchodzi albo tasiemki są uszkodzone. Włożyłem LTO-5 plus wykonałem labels barcode i wszystko przeszło pomyślnie. Dodatkowo wcześniej rewind i weof na każdej.
Przykro nam, ale tylko zarejestrowane osoby mogą pisać na tym forum.

Kliknij żeby zalogować