Niepoprawny Drive index storage-daemon

Wysłane przez malinkalive 
Niepoprawny Drive index storage-daemon 22 sie 2016 - 11:33:33

Send PM

Witam,
zauważyłem, że mam błąd w konfiguracji bacula-sd. Problem wypłyną kiedy bacula chciała zmienić urządzenie/napęd w bibliotece taśm. Zmiana dotyczyła parametru Drive Index z 0 na 1 poniżej stara wg. mnie niepoprawna konfiguracja:

Quote

#
# Define a Virtual autochanger
#
Autochanger {
Name = AutochangerTS3100
Device = TS3100,TS31002
Changer Command = "/home/bacula/scripts/mtx-changer %c %o %S %a %d"
Changer Device = /dev/sg4
}


Device {
Name = TS3100
Drive Index = 0
Media Type = LTO-6
Archive Device = /dev/nst0
LabelMedia = no; # lets Bacula label unlabeled media
Random Access = no;
AutomaticMount = yes; # when device opened, read it
RemovableMedia = yes;
AlwaysOpen = yes;
AutoChanger = yes
Maximum Concurrent Jobs = 15
Device Type = Tape
}

Device {
Name = TS31002
Drive Index = 0 #tutaj zmieniłem na 1 i teraz straciłem możliwość zmieniania taśm w tym urządzeniu
Media Type = LTO-6
Archive Device = /dev/nst1
LabelMedia = no; # lets Bacula label unlabeled media
Random Access = no;
AutomaticMount = yes; # when device opened, read it
RemovableMedia = yes;
AlwaysOpen = yes;
AutoChanger = yes
Maximum Concurrent Jobs = 15
Device Type = Tape
}

Dlatego też zmieniłem Drive Index = 1 dla urzadzenia TS31002 wydaje mi się, że potrzebny jest jeszcze update po stronie bconsole ale chciałem zapytać o składnie ponieważ już mam na tym urządzeniu klilka TB danych.

Poniżej log z próby z zamontowania kasety w doku.
Quote

mount storage=IBMTS3100 drive=1
Automatically selected Catalog: MyCatalog
Using Catalog "MyCatalog"
Enter autochanger slot: 10
3301 Issuing autochanger "loaded? drive 1" command.
3302 Autochanger "loaded? drive 1", result: nothing loaded.
3301 Issuing autochanger "loaded? drive 0" command.
3302 Autochanger "loaded? drive 0", result: nothing loaded.
3301 Issuing autochanger "loaded? drive 1" command.
3302 Autochanger "loaded? drive 1", result: nothing loaded.
3304 Issuing autochanger "load slot 10, drive 1" command.
3992 Bad autochanger "load slot 10, drive 1": ERR=Child exited with code 1.
Results=illegal <drive-number> argument '1' to 'load' command

3301 Issuing autochanger "loaded? drive 1" command.
3302 Autochanger "loaded? drive 1", result: nothing loaded.
3001 Mounted Volume: ACW1014
3001 Device ""TS31002" (/dev/nst1)" is mounted with Volume "ACW1014"

Z góry dziękuje za pomoc.
Re: Niepoprawny Drive index storage-daemon 06 wrz 2016 - 11:08:39

Send PM

Ale restart bacula-sd po zmianach robiłeś?

--
Profesjonalne usługi Bacula: [www.bacula.com.pl]
Przykro nam, ale tylko zarejestrowane osoby mogą pisać na tym forum.

Kliknij żeby zalogować