Automatyczny backup nie wykonuje się , tylko po wywołaniu ręcznym

Wysłane przez masterrtronic 
Automatyczny backup nie wykonuje się , tylko po wywołaniu ręcznym 18 pa 2017 - 10:46:11

Send PM

Po ogarnięciu kilku problemów ...napotkałem kolejny . Automatyczne backupy nie wykonują się w zadanym czasie - nie mam żadnych błędów a pomimo to ..dusza. Jeśli wywołuje backup ręcznie jest ok - będę wdzięczny za pomoc .
bacula-dir -t ok
bacula-sd -t ok
bacula-fd -t ok

wszystkie usługi działają

Mój bacula-dir :

Director {                            # define myself
  Name = cam-dir
  DIRport = 9101                # where we listen for UA connections
  QueryFile = "/etc/bacula/scripts/query.sql"
  WorkingDirectory = "/var/lib/bacula"
  PidDirectory = "/var/run/bacula"
  Maximum Concurrent Jobs = 20
  Password = xxxx
  Messages = Standard
  DirAddress = 10.0.0.8
  MaximumConsoleConnections = 10
  }
JobDefs {
  Name = "Backup_windows"
  Type = Backup
  Schedule = "Cykl tygodniowy"
  Storage = File1
  Messages = Standard
  Pool = Default
  Full Backup Pool = do_plikow
  Incremental Backup Pool = do_plikow_inc
  Priority = 10
  Write Bootstrap = "/var/lib/bacula/%c.bsr"
}
Job {
  Name = laptop
  JobDefs = Backup_windows
  Client = Laptop_it
  FileSet = windows_10
  Maximum Concurrent Jobs = 5
}
Job {
  Name = ksiegowoc_ewa
  JobDefs = Backup_windows
  Client = kold-fd
  FileSet = ksiegowosc_ewa_ustawienia
  Maximum Concurrent Jobs = 5
  Schedule = "Cykl tygodniowy"
}
Job {
  Name = "agnieszka_k"
  JobDefs ="Backup_windows"
  Client = desktop-q6pna8v-fd
  FileSet = "agnieszka_k_ustawienia"
  Maximum Concurrent Jobs = 5
}
Job {
  Name = "RestoreFiles"
  Type = Restore
  Client = Laptop_it
  FileSet="windows_10"
  Storage = File1
  Pool = do_plikow
  Messages = Standard
  Where = "C:/Odtwarzanie_plikow"
  Maximum Concurrent Jobs = 5
}
FileSet {
  Name = windows_10
   Enable VSS = yes
   Include {
     Options {
      signature = MD5
  Compression = GZIP5
                  }
    File = C:/Users/Masterr2
  }

  Exclude {
    File = C:/Users/Masterr2/AppData/Local/Temp
  }
}
FileSet {
  Name = ksiegowosc_ewa_ustawienia
   Enable VSS = yes
   Include {
       Options {
      signature = MD5
  Compression = GZIP5
                  }
    File = C:/Users/UMN
  }

  Exclude {
    File = C:/Users/UMN/AppData/Local/Temp
  }
}
FileSet {
  Name = agnieszka_k_ustawienia
   Enable VSS = yes
   Include {
       Options {
      signature = MD5
  Compression = GZIP5
                  }
    File = C:/Users/SC1
  }

  Exclude {
    File = C:/Users/SC1/AppData/Local/Temp
  }
}
Schedule {
  Name = "Cykl tygodniowy"
  Run = Level=Full Pool=do_plikow fri at 8:30
  Run = Level=Incremental Pool=do_plikow_inc mon-thu at 09:00
}
Storage {
  Name = File1
  Address = 10.0.0.8               # N.B. Use a fully qualified name here
  SDPort = 9103
  Password = "xxxx"
  Device = "urzadzenie plikowe"
  Media Type = File
  Maximum Concurrent Jobs = 20        # run up to 10 jobs a the same time
}
Catalog {
  Name = MyCatalog
  dbname = "bacula"; dbuser = "bacula"; dbpassword = "xxxx"
}
Messages {
  Name = Standard
  mailcommand = "/usr/sbin/bsmtp -h localhost -f \"\(Bacula\) \<%r\>\" -s \"Bacula daemon message\" %r"
  mail = root = all, !skipped
  console = all, !skipped, !saved
  append = "/var/log/bacula/bacula.log" = all, !skipped
  catalog = all, !skipped, !saved
}

Pool {
  Name = Default
  Pool Type = Backup
  Recycle = yes                       # Bacula can automatically recycle Volumes
  AutoPrune = yes                     # Prune expired volumes
  Volume Retention = 365 days         # one year
  Maximum Volume Bytes = 50G          # Limit Volume size to something reasonable
  Maximum Volumes = 100               # Limit number of Volumes in Pool
}

Pool {
  Name = "File1"
  Pool Type = Backup
  Recycle = yes
  Auto Prune = yes
  Volume Retention = 30 days
  #Maximum Volume Bytes = 1000000 MB
  Storage = File1
}

Pool {
  Name = do_plikow
  Pool Type = Backup
  Recycle = yes                       # Bacula can automatically recycle Volumes
  AutoPrune = yes                     # Prune expired volumes
  Volume Retention = 365 days         # one year
  Maximum Volume Bytes = 50G          # Limit Volume size to something reasonable
  Maximum Volumes = 100               # Limit number of Volumes in Pool
  Label Format = "Full-${Client}-"
  Action On Purge = Truncate
  Catalog Files = yes
  Maximum Volume Jobs =0
  Maximum Volume Files = 0
  Volume Use Duration = 0
}

Pool {
  Name = do_plikow_inc
  Pool Type = Backup
  Recycle = yes                       # Bacula can automatically recycle Volumes
  AutoPrune = yes                     # Prune expired volumes
  Volume Retention = 62 days         # one year
  Maximum Volume Bytes = 50G          # Limit Volume size to something reasonable
  Maximum Volumes = 100               # Limit number of Volumes in Pool
  Label Format = "Inc-${Client}-"
  Action On Purge = Truncate
  Catalog Files = yes
  Maximum Volume Jobs =0
  Maximum Volume Files = 0
  Volume Use Duration = 0
}
# Scratch pool definition
Pool {
  Name = Scratch
  Pool Type = Backup
}
Console {
  Name = cam-mon
  Password = xxxx
  CommandACL = status, .status
}
Client {
  Name = Laptop_it
  Password = xxxx
  Address = 10.0.0.238
  FDPort = 9102
  File Retention = 90 days
  Job Retention = 6 months
  AutoPrune = yes
  Catalog = "MyCatalog"
  Maximum Concurrent Jobs = 5
}
Client {
  Name = kold-fd
  Password = xxxx
  Address = 10.0.0.37
  FDPort = 9102
  File Retention = 90 days
  Job Retention = 6 months
  AutoPrune = yes
  Catalog = "MyCatalog"
  Maximum Concurrent Jobs = 5
}
Client {
  Name = desktop-q6pna8v-fd
  Password = xxxx
  Address = 10.0.0.236
  FDPort = 9102
  File Retention = 90 days
  Job Retention = 6 months
  AutoPrune = yes
  Catalog = MyCatalog
  Maximum Concurrent Jobs = 5
}
Re: Automatyczny backup nie wykonuje się , tylko po wywołaniu ręcznym 30 pa 2017 - 14:31:37

Send PM

Znalazłem błąd podzielę się smiling smiley Zabrakło jednego parametru ...aczkolwiek nie wiem czemu parametr musi występować uu mnie sad smiley
Client {
  Name = komp0-think-fd
  Password = xxxx
  Address = 10.0.0.29
  FDPort = 9102
  File Retention = 90 days
  Job Retention = 6 months
  AutoPrune = yes
  Catalog = MyCatalog
  Maximum Concurrent Jobs = 5
  Enabled = Yes
}
Re: Automatyczny backup nie wykonuje się , tylko po wywołaniu ręcznym 06 lis 2017 - 11:36:30

Send PM

To podziel się jeszcze informacjami: jaka wersja Bacula i czy korzystasz z gotowych pakietów z dystrybucji, czy kompilowałeś sam ręcznie?

--
Profesjonalne usługi Bacula: [www.bacula.com.pl]
Re: Automatyczny backup nie wykonuje się , tylko po wywołaniu ręcznym 08 lis 2017 - 10:21:13

Send PM

Cześć, wersja Baculi 7.4.4 , instalowana z gotowych pakietów na Ubuntu serwer 17.10
Re: Automatyczny backup nie wykonuje się , tylko po wywołaniu ręcznym 08 lis 2017 - 11:41:52

Send PM

To ciekawe. Wygląda tak jakby opiekun pakietów Bacula w Ubuntu wprowadził tą zmianę na własną rękę. W Bacula kompilowana ze źródeł (wprawdzie wersja 9.0.5, ale w tym zakresie nic się nie zmieniało):
bacula-dir.conf:
JobDefs {
  Name = "DefaultJob"
  Type = Backup
  Level = Incremental
  Client = swift-fd
  FileSet = "Full Set"
  Schedule = "WeeklyCycle"
  Storage = File1
  Messages = Standard
  Pool = File
  SpoolAttributes = yes
  Priority = 10
  Write Bootstrap = "/opt/bacula/working/%c.bsr"
}
Client {
  Name = swift-fd
  Address = swift
  FDPort = 9102
  Catalog = MyCatalog
  Password = ""
  File Retention = 60 days
  Job Retention = 6 months
  AutoPrune = yes
}
Job {
  Name = "BackupClient1"
  JobDefs = "DefaultJob"
}
do tego wynik z bconsole:
*show job=BackupClient1
Job: name=BackupClient1 JobType=66 level=Incremental Priority=10 Enabled=1
     MaxJobs=1 NumJobs=0 Resched=0 Times=0 Interval=1,800 Spool=0 WritePartAfterJob=1
     Accurate=0

W konfiguracji nie ma Enabled = Yes, a mimo to zadanie jest włączone i wykonuje się automatycznie. Dziwne.

--
Profesjonalne usługi Bacula: [www.bacula.com.pl]
Przykro nam, ale tylko zarejestrowane osoby mogą pisać na tym forum.

Kliknij żeby zalogować